主页 > 知识库 > 数据库 > Oracle >

Oracle 11g安装图文攻略(2)

来源:中国IT实验室 作者:佚名 发表于:2012-08-31 09:27  点击:
9. 先决条件检查。 安装程序会检查软硬件系统是否满足,安装此Oracle版本的最低要求。 直接下一步就OK 了。如图: 10. 概要 安装前的一些相关选择配置信息。 可以保存成文件 或 不保存文件直接点完成即可。如图: 1

9. 先决条件检查。 安装程序会检查软硬件系统是否满足,安装此Oracle版本的最低要求。 直接下一步就OK 了。如图:
 
\

10. 概要 安装前的一些相关选择配置信息。 可以保存成文件 或 不保存文件直接点完成即可。如图:
 
\

11. 安装产品 自动进行,不用管。如图:
 
\

12. 数据库管理软件文件及dbms文件安装完后,会自动创建安装一个实例数据库默认前面的orcl名称的数据库。如图:
 
\

13. 实例数据库创建完成了,系统 默认是把所有账户都锁定不可用了(除sys和system账户可用外),建议点右边的口令管理,将常用的scott账户解锁并输入密码。 如图:
 
\

14. 解锁scott账户, 去掉前面的绿色小勾,输入密码。同样可以输入平常用的短小的密码,不必非得按oracle建议的8位以上大小写加数字,麻烦。呵呵。如图:
 
\

15. 同样,密码不符合规则会提示。不用管它,继续Y即可。如图:
 
\
 
16. 安装成功,完成即可。 简单吧,呵呵。如图:
 
\
 
    三、安装后,进入小测试下。
    可以通过开始,应用程序中的 "Oracle 11g" -> "应用程序开发" -> "Sql Developer 或Sql Plus" 连接。
    注意第一次,使用SQL Developer时,会提示指定 java.exe的路径,这里千万别指定自己的java_home了(我就是开始不知道,指定一个JDK6,结束说不兼容。)可以使用Oracel安装路径下面的jdk路径  具体是:如图:。
 
\

    当然若不小心,选择错了。选择了java_home中的高级版本,打开SQL Developer报错后不兼容,也有办法解决。可以在
    【F:\app\chen\product\11.2.0\dbhome_1\sqldeveloper\sqldeveloper\bin】路径下找到【sqldeveloper.conf】文件后打开
    找到SetJavaHome 所匹配的值,删除后面的配置内容。保证时会提示,只读文件不可覆盖保存。此时可以另存为到桌面上,然后再回到bin目录中删除掉此文件,再把桌面上的文件复制过去,再打开时,重新选择java.exe。此时选择对就好了。

有帮助
(9)
100%
没帮助
(0)
0%